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The small print

Prerequisites
Time in the workshop is precious – it is an opportunity for you to interact with the 
workshop leader and other participants through questions and discussions and to 
share your experiences and concerns. To make the most of this time we sometimes 
ask you to carry out learning activities ahead of the workshop so that everyone 
comes into the class with the same basic knowledge. We keep this prior learning to 
a minimum and often make use of online videos. Online videos provided through 
LinkedIn Learning can be accessed free of charge by University members anytime, 
anywhere, through a browser or app.

Your course booking will tell you if any prior learning activity is required. If you don’t 
have an environment where you can do this learning, you can come along to one of 
our LinkedIn Learning sessions. These are a quiet space where you can work through 
videos or other workshop resources.

If you arrive for a workshop without having done the prior learning, the workshop 
leader may suggest that you come back on another session. 

Copyright
Carl Wenczek makes this booklet and the accompanying slides available under a 
Creative Commons licence (BY-NC-SA: Attribution-NonCommercial-ShareAlike).

The Oxford University crest and logo and IT Services logo are copyright of the 
University of Oxford and may only be used by members of the University in 
accordance with the University’s branding guidelines.

About the workshop designer
Carl Wenczek is a very experienced architectural illustrator and an expert in 3d 
modelling and 2d imaging.  He is a Director of his own small company and over the 
last 21 years has built long lasting relationships with his clients, creating 100’s of 
illustrations and helping them convey their ideas and designs.

Running parallel to his commercial work, Carl is also a part-time lecturer in 
multimedia and has been teaching at Oxford University’s IT Services for the last 20 
years, delivering courses in Photoshop, Illustrator, InDesign, After Effects, Blender, 
GIMP, Inkscape and digital photography.

Carl also coaches Paddlesport (kayaking, canoeing and stand up paddling) and 
Indoor Climbing.  These sports are often coached in demanding and dynamic 
environments and require a calm persona!

Revision history

Version	 Date			   Author			   Comments

1.0	 February 2024		  Carl Wenczek		  First version
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About this workshop

What you will learn
This course guides people through the process of optimizing and saving images for 
the web.  The course will broadly cover 3 subject areas: types of images; resizing 
images; and saving images.  There will be a mixture of explanation, demonstration 
and hands-on tasks.

What you need to know
You do not need any prior knowledge of the software used during this workshop.

This workshop will cover:

•	 Selecting appropriate images and image formats.  This includes usage scenarios, 
and image make up and formats.

•	 Cropping, resizing and sharpening images.
•	 Use of colour profiles and saving images.

If you need to review these activities, LinkedIn Learning is a great place to get 
guidance. There is an activity with relevant videos in the IT Learning Portfolio: visit 
skills.it.ox.ac.uk/it-learning-portfolio and search for “Images” or “Images activity”.

The resources you need
Sample documents that you can use to experiment with will be made available, but 
you may like to bring along your own.

The resources for most workshops, including any pre-course activity, are in the 
IT Learning Portfolio: visit skills.it.ox.ac.uk/it-learning-portfolio and search for 
“Images”.

Unless you have been told otherwise, in classroom workshops there will be a 
computer available for you to use with the following applications installed:

•	 GIMP
•	 Adobe Photoshop
•	 Adobe Bridge
•	 Adobe Acrobat Reader
•	 Microsoft Word
•	 A web browser such as Google Chrome

You can use your own computer with your preferred apps installed if you want to 
– just bear in mind that I am not an expert in every app (although I am sure that 
between us we will be able to sort out most problems!)

http://skills.it.ox.ac.uk/it-learning-portfolio
http://skills.it.ox.ac.uk/it-learning-portfolio
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Correcting and 
Improving your 
images
A digital workflow

1.	 Evaluate images
2.	 Rotate, crop and correct perspective
3.	 Reduce noise and repair blemishes
4.	 Capture Sharpening
5.	 Tonal range adjustment
6.	 Colour balance
7.	 Saturation
8.	 Selective correction
9.	 Fine tuning of colours
10.	Adjust mid-tone contrast
11.	 Resize image for final media
12.	Sharpen for final media
13.	Save

Learning Objective 01 - A digital workflow
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Learning Objective 02 - Scenarios

We use images for a variety of different purposes:  for websites, social media, email 
marketing, PowerPoint presentations, newletters, magazines, research papers, 
posters and flyers, and so on.

These uses, or intents, can be broadly grouped into two categories:
•	 Screen based
•	 Print based

Each intent requires the use of specific file formats such as .tiff, .jpg, .gif, .png, .pdf, 
.eps, .wmf and so on.

For websites and social media we use either JPG, PNG or GIF

JPG
For complex images with no text, such as digital photographs.

PNG
For text, graphics with hard edges, and elements that require transparent 
backgrounds like logos.

GIF
GIF files will load quicker than PNG files however they are limited to 256 colours.  
Use GIF for elements like solid color buttons or banners, and simple solid colour 
elements that require transparency.  GIF files can utilize animation, so you can 
create graphics with a short looping or single play animation.

Task
Examine a website and discuss with your teacher the different file formats that 
might have been used.

https://www.mohash.co/?ref=onepagelove

https://www.britishcanoeing.org.uk/

https://www.mohash.co/?ref=onepagelove
https://www.britishcanoeing.org.uk/
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Learning Objective 03 - Image makeup and file formats

Image makeup
Images can be made of pixels (raster) or generated mathematically (vector).

Raster images are resolution dependent whereas vector images are resolution 
independent.

For websites and social media we typically use raster images.

File formats

Images can be uncompressed, or compressed to reduce file size.

File format Compression Colour For web?
TIFF Yes, lossless RGB and CMYK No
PNG Yes, lossless RGB Yes
JPEG Yes, lossy RGB Yes
GIF Yes, lossy RGB (256 colours) Yes

Task
Save a vector graphic as a JPG and a PNG to compare the difference.

.TIFF

.JPG

.PNG

.AI

.SVG

.WMF

.EPS

.PDF

.PSD

.AI

.SVG
.WMF

.EPS

.PDF

.PSD

Vector Raster

.GIF
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Image makeup
Images typically come in 2 colour formats, RGB (screen, web, social media) and 
CMYK (print).  We will revisit this later when we look at colour profiles.

To ensure your image is 
using RGB colours choose 
Image>Mode for both 
Photoshop and GIMP
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Learning Objective 04 - Cropping images

For a website you may want to crop an image without being to concerned about 
using a specific aspect ratio.  You may just crop by eye and then resize the image 
later.

For social media there are defined aspect ratios for different uses on the various 
apps and platforms.

Cropping images to a specific aspect ratio for social media

• For Photoshop choose the Crop tool 

Then, from the Options panel choose Ratio and set your ratio.

• For GIMP choose the Crop Tool 

Then from the Tool Options panel choose Aspect ratio, ensure the Fixed box is 
checked and set your ratio.

For a guide to social media image 
sizes and aspect ratios visit:

https://blog.hootsuite.com/social-
media-image-sizes-guide/

https://blog.hootsuite.com/social-media-image-sizes-guide/
https://blog.hootsuite.com/social-media-image-sizes-guide/
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Learning Objective 05 - Image size for the web and social media

For the web and social media

Pixel dimensions only.

“Unoptimized images slow down websites.  Slow websites = bad user 
experience, lower chances to rank in Google searches and ultimately less 
inquiries and customers.”

When it comes to displaying images on a screen you need to be aware of the size of 
the screen or monitor you will be using to display your images.  For example, to fill 
a monitor that is 1920 by 1080 pixels in size so, you will need an image that is 1920 
by 1080 pixels in size.

Date Other High 1920x1080 1366x768 1280x1024 1280x800 1024x768 Lower

January 
2023

47.2% 18.4% 18.2% 1.1% 1.0% 0.7% 13.4%

https://www.w3schools.com/browsers/browsers_display.asp

• For Photoshop use the Image Size command
Image>Image Size...

• For GIMP choose Scale Image
Image>Scale Image...

For a more thorough explanation and guide visit:

https://flothemes.com/flothemes-image-sizes/

For a guide to social media image sizes and aspect ratios visit:

https://blog.hootsuite.com/social-media-image-sizes-guide/

https://www.w3schools.com/browsers/browsers_display.asp
https://flothemes.com/flothemes-image-sizes/
https://blog.hootsuite.com/social-media-image-sizes-guide/
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Learning Objective 06 - Sharpen an image

Sharpening is a technique for increasing the apparent sharpness of an image.  It 
can be used to emphasize texture and draw viewer focus.  Sharpening needs to be 
carried out carefully because if it is applied too aggressively artifacts may appear or 
an image can appear too sharp.  For more information see:

https://www.cambridgeincolour.com/tutorials/image-sharpening.htm

Capture 
Sharpening

Creative 
Sharpening

Output 
Sharpening

Reduce blurring 
caused by the 
source of your 
image e.g. camera 
sensor, camera 
lens

Applied selectively 
and for artistic 
purposes

Appropriate to 
final media and to 
offset any softening 
caused by resizing 
an image

Common settings

Radius:  Controls the size of the edges you wish to enhance, where a smaller radius 
enhances smaller-scale detail.  Choose a radius setting that is comparable to the 
size of the smallest detail within your image.  Try starting at a value of 1.

Amount:  Controls the overall strength of the sharpening effect, and is usually 
listed as a percentage.  Try starting at a value of 100%.

Threshold (Masking):  Controls the minimum brightness change that will be 
sharpened.  This can be used to sharpen more pronounced edges, while leaving 
more subtle edges untouched.  It is especially useful to avoid sharpening noise.

• For Photoshop use Smart Sharpen or Unsharp Mask filters 
(Filter>Sharpen>).

• For GIMP use the Sharpen or Unsharp Mask filters (Filters>Enhance>).

https://www.cambridgeincolour.com/tutorials/image-sharpening.htm
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Learning Objective 07 - Colour profiles

Colour profiles define the colours we capture with our cameras and see on our 
displays.  They control what colours are used and help provide consistency between 
devices.

Our eyes can see far more colours than a camera can capture or a monitor can 
display. This means we need some way to define the subset of colours that cameras 
can capture and monitors can display.  We also need a way to keep colours 
consistent between the two.  A certain shade of red that a camera captures should 
look the same shade of red on a monitor.  This is where colour spaces and colour 
profiles come in.

With the RGB color model, we can display (or capture) 16.7 million colours.  But 
the question is, which 16.7 million colours to use?  This is where a colour profile 
comes in.

sRGB
sRGB is the standard profile used on the web.

For more information visit:

https://www.howtogeek.com/343900/what-is-a-color-profile/

https://www.howtogeek.com/343900/what-is-a-color-profile/
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Converting between colour profiles

Adobe RGB
The Adobe RGB colour profile is designed to display a wider range of the visual 
spectrum than sRGB.  It’s mainly used by professional photographers and most 
high-end cameras can capture Adobe RGB.

If you have captured your image using a colour profile other than sRGB, such as 
Adobe RGB, you will need to convert it to sRGB before using it on the web or on 
social media.

• In Photoshop we can use Edit>Convert to Profile...

• In GIMP use Image>Color Management>Convert to Color Profile...

In both GIMP and Photoshop you will have 4 Rendering Intents to choose from:  
Perceptual, Saturation, Relative Colormetric, and Absolute Colormetric.

A Rendering Intent is a mathematical method of mapping colours from one colour 
space to another.  For a more indepth explanation of Rendering Intents go to:

https://helpx.adobe.com/photoshop-elements/kb/color-management-settings-
best-print.html#main-pars_header_1

For best results choose either Perceptual or Relative Colormetric.

https://helpx.adobe.com/photoshop-elements/kb/color-management-settings-best-print.html#main-pars_he
https://helpx.adobe.com/photoshop-elements/kb/color-management-settings-best-print.html#main-pars_he
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Learning Objective 08 - Save your images

• For Photoshop use File>Export>Export As...

• For GIMP use File>Export As...
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Learning Objective 09 (Optional) - Create Batch processes

Sometimes you might have a lot of images you need to edit. You may need them all 
at a specific size or want them all to follow a specific naming convention.  Rather 
than editing them one by one you might want to consider setting up a batch process 
to do the work for you.

There are many standalone Batch Image Processors available.  However, 
Photoshop comes with this feature included in the form of Actions and the Batch 
command.

For Photoshop:
• Use the Actions panel.

A Photoshop Action allows you to record a series of steps and then play the 
sequence back to apply those effects on a single image or a batch of files.

• To run an Action on a series of images choose File>Automate>Batch.

For GIMP:
• Use the Batch Mode, see https://www.gimp.org/tutorials/Basic_Batch/

https://www.gimp.org/tutorials/Basic_Batch/
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Further information

Getting extra help

Course Clinics
The IT Learning Centre offers bookable clinics where you can get pre- or post-course 
advice. Contact us using courses@it.ox.ac.uk

Study Videos from LinkedIn Learning
On our website, you will find our collection of self-service courses and resources. This 
includes providing LinkedIn Learning video-based courses free to all members of 
the University. Visit skills.it.ox.ac.uk/linkedin-learning and sign in with your Single 
Sign-On (SSO) credentials.

Some courses recommend pre- and/or post-course activities to support your learning. 
You can watch the online videos anywhere, anytime, and even download them onto a 
tablet or smartphone for off line viewing.

About the IT Learning Portfolio online
Many of the resources used in the IT Learning Centre courses and workshops are 
made available as Open Educational Resources (OER) via our Portfolio website at 
skills.it.ox.ac.uk/it-learning-portfolio.
Find the pre-course activity for this course in the IT Learning Portfolio: visit skills.
it.ox.ac.uk/it-learning-portfolio and search for “Images” or “Images activity”.

About the IT Learning Centre
The IT Learning Centre delivers over 100 IT-related teacher-led courses, which are 
provided in our teaching rooms and online, and we give you access to thousands of 
on-line self-service courses through LinkedIn Learning.

Our team of teachers have backgrounds in academia, research, business and 
education and are supported by other experts from around the University and 
beyond.

Our courses are open to all members of the University at a small charge. Where 
resources allow, we can deliver private courses to departments and colleges, which 
can be more cost-effective than signing up individually. We can also customize 
courses to suit your needs.

Our fully equipped suite of seven teaching and training rooms are usually available 
for hire for your own events and courses.

For more information, contact us at courses@it.ox.ac.uk.

mailto:courses%40it.ox.ac.uk?subject=IT%20Learning%20Centre%20-%20bookable%20clinics
http://skills.it.ox.ac.uk/linkedin-learning
http://skills.it.ox.ac.uk/it-learning-portfolio
http://skills.it.ox.ac.uk/it-learning-portfolio
http://skills.it.ox.ac.uk/it-learning-portfolio
mailto:courses%40it.ox.ac.uk?subject=Courses%20at%20the%20IT%20Learning%20Centre
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About IT Customer Services
The IT Learning Centre is part of the Customer Services Group. The group provides 
the main user support services for the department, assisting all staff and students 
within the University as well as retired staff and other users of University IT services. 
It supports all the services offered by IT Services plus general IT support queries from 
any user, working in collaboration with local IT support units.

The Customer Services Group also offers a data back-up service; an online shop; 
and a computer maintenance scheme. Customer Services is further responsible for 
desktop computing services – for staff and in public/shared areas – throughout UAS 
and the Bodleian Libraries.
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