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The small print

Prerequisites
Time in the workshop is precious – it is an opportunity for you to interact with the 
workshop leader and other participants through questions and discussions and to 
share your experiences and concerns.  To make the most of this time we sometimes 
ask you to carry out learning activities ahead of the workshop so that everyone 
comes into the class with the same basic knowledge.  We keep this prior learning to 
a minimum and often make use of online videos.  Online videos provided through 
‘Molly’ can be accessed by University members anytime, anywhere, through a 
browser or app.

Your course booking will tell you if any prior learning activity is required.  If you don’t 
have an environment where you can do this learning, you can come along to one of 
our ‘quiet’ sessions.  These are scheduled every week in normal term-time, and are a 
quiet space where you can work through ‘Molly’ videos or other workshop resources.  
If you turn up for a workshop without having done the prior learning, the workshop 
leader may suggest that you come back on another session. 

Copyright
Carl Wenczek makes this booklet and the accompanying slides available under a 
Creative Commons licence (BY-NC-SA: Attribution-NonCommercial-ShareAlike).  
The Oxford University crest and logo and IT Services logo are copyright of the 
University of Oxford and may only be used by members of the University in 
accordance with the University’s branding guidelines.

About the workshop designer
Carl Wenczek is a very experienced architectural illustrator and an expert in 3d 
modelling and 2d imaging.  He is a Director of his own small company and over the 
last 18 years has built long lasting relationships with his clients, creating 100’s of 
illustrations and helping them convey their ideas and designs.

Running parallel to his commercial work, Carl is also a part-time lecturer in 
multimedia and has been teaching at Oxford University’s IT Services for the last 17 
years, delivering courses in Photoshop, Illustrator, InDesign, After Effects, Blender, 
GIMP, Inkscape and digital photography.

Carl also coaches Paddlesport (kayaking, canoeing and stand up paddling) and 
Indoor Climbing.  These sports are often coached in demanding and dynamic 
environments and require strong leadership skills and a calm persona! 

Revision history

Version Date   Author   Comments

1.0 April 2019  Carl Wenczek  First version, full day course
2.0 January 2020 Carl Wenczek  Converted to a 3 hour course
2.1 May 2020  Carl Wenczek  Updated further information  
         text



About this workshop

Adobe After Effects is the leading professional software for motion graphics, video 
compositing and visual effects.

What you will learn
In this workshop you will learn to create 2d animations using vector graphics.

What you need to know
You do not need any prior knowledge of Adobe After Effects.  Experience using 
Photoshop (GIMP) or Illustrator (Inkscape) will be to your advantage, but not 
necessary.

This workshop will cover:

•	A	workflow
•	Introduction	to	Adobe After Effects
•	Setting	up	a	new	project
•	Working	with	the	timeline
•	Importing	vector	artwork
•	Basic	animation
•	Exporting	the	animation

If you need to review these activities, Molly is a great place to get guidance.  There is 
an activity with relevant Molly videos in the IT Learning Portfolio: visit skills.it.ox.
ac.uk/it-learning-portfolio and search for “Adobe After Effects”.

The resources you need
Sample documents that you can use to experiment with will be made available, but 
you may like to bring along your own.

Unless you have been told otherwise, in classroom workshops there will be a 
computer available for you to use with Adobe After Effects installed.

You can use your own computer with your preferred app installed if you want to 
–	just	bear	in	mind	that	I	am	not	an	expert	in	every	app	(although	I	am	sure	that	
between us we will be able to sort out most problems!).
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Learning Objective 01 -  Introduction and the Interface

What Can After Effects Do?  After Effects (AE) is not an editing program; if 
you	want	to	edit	a	video,	Final	Cut	Pro	and	Premiere	do	a	much	better	job	than	AE.		
In the industry, AE is commonly used for producing animated infographics, title 
sequences	and	integrating	graphics	with	film	footage.

1 = File menu
2 = Tool bar (at the top of the interface you will find the tool bar which allows 
you to activate different tools)
3 = Project and Effect Controls Windows (lists your footage and stock 
resources)
4	=	Composition Window (the preview window and the main animation space 
that you work in when building an AE project)
5	=	Panels
6	=	The Timeline and Render Queue (this is where most of your animation 
work will be done)



Learning Objective 02 - Setting up a new Project and 
Composition

Project:		An	After	Effects	project	is	a	single	file	that	stores	compositions.

Composition:  A composition is the framework for a movie. Each composition 
has its own timeline.  A typical composition includes multiple layers that 
represent components such as video and audio footage items, animated text and 
vector	graphics,	still	images,	and	lights.		Simple	projects	may	include	only	one	
composition;	complex	projects	may	include	hundreds	of	compositions	to	organize	
large amounts of footage or many effects.

Task

•	Create	a	new	Project and then create a new Composition 
(Composition>New Composition...)

Preset = HDV/HDTV 720 29.97
Duration=	0;	00;	05;	00	(5	seconds)

More information can be found at the back of these notes.

•	Composition	settings	can	be	changed	by	going	to	Composition>Composition 
Settings...

•	Save	your	project	by	chosing	File>Save As.



Learning Objective 03 - Time and the Timeline

Take a look at the Timeline.  You will notice that the duration of your animation 
is indicated horizontally, along the top of the Timeline, in what is called the Time 
Ruler.

The Time Ruler displays the duration as a combination of frames and seconds (by 
default, After Effects displays time in Society of Motion Picture and Television 
Engineers (SMPTE) timecode: hours, minutes, seconds, and frames).

The duration of your current composition can be lengthened or shortened by going 
to Composition>Composition Settings...



Learning Objective 04 - Importing artwork from Adobe 
Illustrator

After Effects (AE) has a fairly limited set of vector drawing and editing tools.  
Therefore, it is best to create more complex artwork in an application like Adobe 
Illustrator and then import the artwork into AE.

Task

Import	an	Illustrator	file.

•	File>Import>File...

Once	imported,	your	Illustrator	file	will	appear	in	the	Project window as one of 
the resources available for you to use in your composition.

To	use	the	file,	drag	it	down	into	the	Timeline.

Considerations:

•	Centre	the	Anchor	Point	(Layer>Transform>Centre Anchor Point in 
Layer Content).

•	If	you	are	going	to	scale	your	Illustrator	file	ensure	you	enable	Continuously 
Rasterize.



Learning Objective 05 - Creating Shapes and Shape Layers

After	Effects	includes	five	shape	tools:	Rectangle,	Rounded	Rectangle,	Ellipse,	
Polygon, and Star.

When you draw a shape directly in the Composition panel, After Effects 
adds a new shape layer to the composition.

You	can	apply	stroke	and	fill	settings	to	a	shape,	modify	its	path,	and	apply	
animation presets.  Shape attributes are all represented in the Timeline panel, and 
you can animate each setting over time.

Task:

•	What	happens	if	you	create	two	shapes,	one	after	the	other?
...

•	What	happens	if	you	deselect	the	first	shape	before	creating	a	second	shape?
...

•	Try	changing	the	Fill	and	Stroke	attributes	of	your	shapes.

Remember to name your Shape Layers!



Learning Objective 06 - Moving Shapes in a straight line

Before we animate a shape moving in a straight line let’s examine the Shape 
Layer and the various transformation options.

Task

•	Create	two	shapes	in	the	same	Shape	Layer.

•	Examine	the	difference	between	Shape	Layer	transformations	and	Content	
transformations.
...

Keyframes

A key frame or keyframe is a location on a timeline which marks the beginning or 
end	of	a	transition.		It	holds	special	information	that	defines	where	a	transition	
should start or stop.  The intermediate frames are interpolated over time between 
those	definitions	to	create	the	illusion	of	motion.

Task

•	Animate	the	shapes	moving	in	a	straight	line	using	the	Position property stop 
watch.

•	Try	Content	transformation	and	the	Shape	Layer	transformation.

Task

•	Right-click	on	a	keyframe	for	either	Keyframe Assistant or Keyframe 
Interpolation...

•	Change	keyframes	from	Linear	to	Ease	In/Ease	Out.



Learning Objective 07 - Add Fade

You can animate different properties of the same shape to give a combined effect.

Task

•	Continue	working	with	the	shapes	you	created	in	the	previous	task.

•	Add	fade	to	your	moving	shapes	by	animating	the	Opacity property.



Learning Objective 08 - Create a new Composition

Think	of	your	animation	as	a	film.		Films	are	usually	composed	of	a	series	of	scenes.		

In After Effects we can think of Compositions as being like scenes.

It is easier to break your animation down into a series of Compositions (scenes) 
and then combine these together later.

Task

•	Create	a	new	Composition	(Composition>New Composition...)

•	The	settings	for	this	new	Composition	should	be	the	same	as	for	the	previous	one	
you created.

•	Your	Compositions	will	appear	in	the	top-left	corner	of	the	Timeline	and	Render	
Queue panel.

Considerations:

•	It	is	probably	a	good	idea	to	rename	your	Compositions.		How	do	you	think	you	
can do this?
...



Learning Objective 09 - Move a Shape while changing colour

Task

•	Using	your	new	Composition,	create	a	new	shape.

•	Move	the	shape	in	a	straight	line	and	add	a	colour	change	by	animating	the	Fill 
Colour property.



Learning Objective 10 - Scaling

Animating a shape changing Scale is a very important and fundamental technique 
to master.  Using scale you can make shapes appear to squash and squeeze when 
they bounce, grow or seem to move closer or receed into the distance.

Task

•	Begin	by	animating	a	shape	scaling	up	or	down.

•	Introduce	movement	by	animating	the	Position	property.

•	Try	a	non-uniform	scale.
...

Considerations:

•	What	happens	if	you	change	scale	after	altering	the	position	of	the	anchor	point?
...

•	Use	the	Pan Behind (Anchor Point) Tool and/or 
Layer>Transform>Centre Anchor Point in Layer Content.



Learning Objective 11 - Rotating

Rotation	is	the	final	transformation	property	we	will	examine.		As	with	the	
other properties we have animated so far, rotation can be combined with other 
tranformations.

Task

•	Begin	by	animating	a	shape	rotating.

•	Then	introduce	movement	while	the	shape	is	rotating.

There are two methods of rotating a shape associated with the Rotation property.  
Can you work out what they are and how they work?
...

•	Finally,	rotate	a	shape	while	changing	the	position	of	it’s	Anchor Point.



Learning Objective 12 - Copying Keyframes

Building on the last task, copy keyframes to animate the shape spiralling back to 
it’s starting position.

Task

Select keyframe(s) and copy (Ctrl + C) , advance time and paste keyframe(s) (Ctrl 
+ V)

Have a go at moving keyframes as well.
...



Learning Objective 13 - Stacking up Compositions

In Learning Objective 08 we discussed how we can think of Compositions as being 
like scenes and how we can combine these Compositions (scenes) to make our 
completed	film.

It is now time to put this into practice.

You	will	have	a	Project	that	consists	of	a	number	of	Compositions.

Task

•	Check	through	your	Compositions	and	rename	them	if	necessary.

•	Create	a	New Composition	that	will	be	your	finished	film.		Call	this	
Composition “Film”.  You may need to make the duration of this new Composition 
longer.

•	Add	some	of	your	existing	Compositions	by	clicking-and-dragging	them	from	the	
Project window into the Timeline window.

•	Experiment	with	dragging	the	individual	Compositions	along	the	timeline	to	
stagger their start times.
...



Learning Objective 14 - Stretching time

The duration of you Compositions can be increased or decreased by scaling the 
length of the time bar or the distance between keyframes.

In this task we will scale down the length of the time bars for the Compositions to 
decrease their durations.

Task

•	Select	a	Composition’s	time	bar	in	the	Timeline	window.

	•	Hold	down	Alt while dragging the end of the time bar left or right to either 
increase or decrease the duration of the Composition.

Task

Before	we	finish	this	learning	objective	try	the	following	to	see	what	happens:

•	Change	the	parameters	of	one	of	the	Compositions	you	used	in	your	final	“Film” 
Composition.

•	Go	to	your	“Film” Composition and see if the change has been carried over.
...



Learning Objective 15 - Creating Text

Animating text layers is useful for many purposes, including animated titles, credit 
rolls, and dynamic typography.

As with other layers in After Effects, you can animate entire text layers.  However, 
text layers offer additional animation features with which you can animate the 
text within the layers.  You can animate text layers by using any of the following 
methods:

•	Animate	the	Transform	properties,	as	you	would	any	other	layer,	to	change	the	
entire layer, not its text contents.

•	Animate	the	source	text	of	the	layer,	so	that	the	characters	themselves	change	to	
different characters or use different character or paragraph formats.

•	Use	text	animators	to	animate	many	properties	of	individual	characters	or	a	range	
of characters (Learning Objective 16).

Task

•	To	place	text,	select	the	Type tool in the Tools panel, click in the Composition 
window, and type.  Use the Selection tool to reposition the text.

•	Choose	fonts,	size,	colour,	justification,	and	other	text	properties	in	the	
Character and Paragraph panels.

•	Once	you	have	created,	formatted	and	positioned	your	text	look	at	the	Timeline.		
You will see a solid red bar.  Try dragging the start and the end of this red bar to 
different positions along the Timeline and then preview the animation.  What 
happens?
…



Learning Objective 16 - Text Animators

Text animators make it relatively easy to create sophisticated text animation in 
After Effects.  We will be looking at two text animators, Position and Opacity.

Task

•	Create	a	New Composition… and type some text e.g. “typewriter text”

•	From	the	Source Text area locate the text animators and choose Position.  
Fully expand the Range Selector area so that you can see all the options.

•	Set	the	starting	position	of	your	text	using	the	Position property.

•	Animate	the	Start property from 0% at the beginning of the animation and 
finishing	at	100%.

•	Try	creating	a	mask.
…

Task

•	Fade	text	in,	letter	by	letter,	using	the	Opacity animator.

•	Tip:		Remember	to	set	the	Opacity property to zero, then animate the Range.  
Leave the Opacity property once you have set the starting state.
…



Learning Objective 17 - Rendering and Output

The primary way of rendering and exporting movies from After Effects is through 
the Render Queue panel.

When you place a composition into the Render Queue panel, it becomes a render 
item.  You can add many render items to the render queue, and After Effects can 
render multiple items in a batch, unattended.  When you click the Render button 
in the upper-right corner of the Render Queue panel, all items with the status of 
Queued are rendered and output in the order in which they are listed in the Render 
Queue panel.

For more information visit https://helpx.adobe.com/uk/after-effects/using/
basics-rendering-exporting.html

Task

•	Add	a	Composition	to	the	Render	Queue	(Compostion>Add to Render 
Queue).

•	From	the	Output Module choose Lossless AVI.

•	Choose	a	file	name	and	location	from	Output To.

•	Click	the	Render	button	to	generate	the	finished	movie.



Keyboard shortcuts and Menu options

Ctrl (Command), Alt (Option)

Ctrl + Move = snap

Ctrl + Pan Behind (Anchor Point) Tool = snap

Alt + draw shape = editable shape

Alt + drag keys = scale time between keys

Right-click	on	keysframe	for	Keyframe	Assistant	and	Keyframe	Interpolation...

Right-click on Position Transform and choose Separate Dimensions to separate the 
x and y coordinates

File	>	Project	Settings...

Edit > Preferences

Edit > Duplicate (to duplicate a Composition)

Composition > New Composition...

Composition > Composition Settings

Composition > Add to Render Queue

Animation	>	Reveal	Properties	with	Keyframes

Layer > Transform > Centre Anchor Point in Layer Content

Layer > Transform > Centre In View

Layer > Mask and Shape Path > Set First Vertex

Layer > Pre-compose...

Shape Layer’s Transform shows the animation path

Contents Transform does not show the animation path



Frame Rates

Myelinated	nerves	can	fire	between	300	to	1000	times	per	second	in	the	human	body	and	
transmit information at 200 miles per hour. What matters here is how frequently these 
nerves	can	fire	(or	“send	messages”).

The nerves in your eye are not exempt from this limit. Your eyes can physiologically 
transmit data that quickly and your eyes/brain working together can interpret up to 1000 
frames per second.

However, we know from experimenting (as well as simple anecdotal experience) that there 
is a diminishing return in what frames per second people are able to identify. Although 
the human eye and brain can interpret up to 1000 frames per second, someone sitting in a 
chair and actively guessing at how high a framerate is can, on average, interpet up to about 
150	frames	per	second.

The	point:	60	fps	is	not	a	‘waste’.	120	fps	is	not	a	‘waste’	(provided	you	have	a	120hz	
monitor	capable	of	such	display).	There	IS	a	very	noticable	difference	between	15	fps	and	
60	fps.	Many	will	say	there	IS	a	noticeable	difference	between	40	and	60	fps.	Lastly,	the	
limit	of	the	human	eye	is	NOT	as	low	as	30-60	fps.	It’s	just	not.

The origin of the myth: The origin of the myth probably has to do with limitations of 
television	and	movies.	Movies,	when	they	were	recorded	on	film	reel,	limited	themselves	to	
24	frames	per	second	for	practical	purposes.	If	there	is	a	diminishing	return	in	how	many	
frames	people	can	claim	to	actually	notice,	then	the	visual	difference	between	24	fps	and	
60	fps	could	not	justify	DOUBLING	the	amount	of	film	reel	required	to	film	a	movie.

With the advent of easy digital storage, these limitations are mostly arbitrary anymore.

The	numbers	often	cited	as	the	mythological	“maximum”	the	eye	can	see	are	30	fps,	40	fps,	
and	60	fps.

I	would	guess	the	60	fps	“eye-seeing”	limit	comes	from	the	fact	that	most	PC	monitors	
(and	indeed	many	televisions	now)	have	a	maximum	refresh	rate	of	60hz	(or	60	frames	per	
second).	If	a	monitor	has	that	60	fps	limit,	the	monitor	is	physically	incapable	of	displaying	
more	than	60	fps.	This	is	one	of	the	purposes	of	frame	limiting,	Vsync	and	adjusting	
refresh rate in video games.

The human eye can physiologically detect up to 1000 frames per second. The average 
human, tasked with detecting what framerate he/she is looking at, can accurately guess up 
to	around	150	fps.	That	is,	they	can	see	the	difference	in	framerates	all	the	way	to	150	fps.

Aninda Dutta, Student at KIIT University (2016-present)



Why 29.97 fps not 30 fps?

It is fairly common knowledge that the video on your TV is playing at 30 frames per 
second	(fps)	—	unless	you	live	in	europe	where	it	is	25fps.	However,	have	you	ever	
thought	about	why	these	are	the	frame	rates?	Why	not	50	or	100?	You	probably	
haven’t, but since I think about moving pictures all day I actually know the answer 
to this.

The main thing I would like to point out, which some of the geekier of you might 
already	know,	is	that	30fps	is	just	an	approximation	of	the	actual	frame	rate	of	
video in the US. The real framerate is 29.97fps. Why this incredibly strange number 
you say? Well, I’ll tell you.

In	order	to	make	video	play	back	at	a	fixed	rate	there	needs	to	be	some	kind	of	
timing	circuit.	When	television	was	first	beginning,	there	weren’t	any	of	the	high	
tech silcon-based chips that we used for this task today. So the brilliant engineers 
back then used the oscillation of AC electricty as the basis for their timing circuit. 
In	the	US,	electricity	cycles	at	60	times	per	second	(60hz.)	So	using	half	of	that	
gives	us	the	frame	rate	of	30fps.	(In	Europe,	electricity	flows	at	50hz.	50/2	=	25fps)

So the frame rate of television was actually exactly 30 frames per second at one 
point in time. However that all changed when color television was introduced. 
When a signal for color information was added to the television transmission there 
was a big problem. The color carrier signal was phasing with with the sound carrier 
signal because they were very close in the spectrum. This made the picture look un-
watchable.	The	quick	fix	they	came	up	with	was	to	reduce	the	framerate	by	.03fps	
which moved the two signals out of phase.

We have been stuck with this frame rate ever since.

Source: Wikimedia Commons



Further information

Drop frame:

https://www.connect.ecuad.ca/~mrose/pdf_documents/timecode.pdf

NTSC and PAL:

PAL = Europe

NTSC = America

https://ihffilm.com/videostandard.html



Getting extra help

Course Clinics
The IT Learning Centre offers bookable clinics where you can get pre- or post-course 
advice.  Contact us using courses@it.ox.ac.uk.

Study Videos from Molly
Molly is our collection of self-service courses and resources.  This includes providing 
LinkedIn Learning video-based courses free to all members of the University.  Visit 
skills.it.ox.ac.uk/molly and sign in with your Single Sign-On (SSO) credentials.

Some courses recommend pre- and/or post-course activities to support your learning.  
You can watch these online videos anywhere, anytime, and even download them onto 
a tablet or smartphone for off line viewing.

If you need a quiet place to work through learning activities away from distractions, 
the IT Learning Centre offers ‘quiet’ sessions where you can book a place.  These are 
scheduled frequently during normal term times.

About the IT Learning Portfolio online
Many of the resources used in the IT Learning Centre courses and workshops are 
made available as Open Educational Resources (OER) via our Portfolio website at 
skills.it.ox.ac.uk/it-learning-portfolio.

Find the pre-course activity for this course in the IT Learning Portfolio: visit 
skills.it.ox.ac.uk/it-learning-portfolio and search for “Adobe After Effects”.

About the IT Learning Centre
The IT Learning Centre delivers over 100 IT-related teacher-led courses, which are 
provided in our teaching rooms and online, and we give you access to thousands of 
on-line self-service courses through Molly (powered by LinkedIn Learning).

Our team of teachers have backgrounds in academia, research, business and 
education and are supported by other experts from around the University and 
beyond.

Our courses are open to all members of the University at a small charge.  Where 
resources allow, we can deliver closed courses to departments and colleges, which can 
be more cost-effective than signing up individually.  We can also customize courses to 
suit your needs.

Our fully equipped suite of seven teaching and training rooms are usually available 
for hire for your own events and courses.  For more information, contact us at 
courses@it.ox.ac.uk.



About IT Customer Services
The IT Learning Centre is part of the Customer Services Group.  The group provides 
the main user support services for the department, assisting all staff and students 
within the University as well as retired staff and other users of University IT services.

It supports all the services offered by IT Services plus general IT support queries from 
any user, working in collaboration with local IT support units.

The Customer Services Group also offers a data back-up service; an online shop; and 
a PC maintenance scheme.  Customer Services is further responsible for desktop 
computing services – for staff and in public/shared areas – throughout UAS and the 
Bodleian Libraries.


