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NVivo 1 for Windows – Walking before 

Running: Code and Retrieve



Take a moment to check you have everything you need.

Have you got your:

1) Course slides

2) NVivo v1 installed with Licence Key enabled

3) Work files/data provided for this session

4) Something to write with, and write on

We are working with data 

that should already be on 

your computer.

Have you saved this 

somewhere easy to find?
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• Navigate your way round NVivo

• Import text data into NVivo

• Code text data

• Make notes about your data

• Retrieve coded data using ‘queries’

Learning objectives -

Today you will find out how to:
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FIRST THINGS FIRST…

WELCOME!

Today you’re with Susie and Charlotte.

Online teaching is not as straightforward as teaching in-person. 
You’re in safe hands, but sometimes the online environment may 
make the class more ‘exciting’. Please bear with us.

If your computer has a problem (for example with your  internet 
connection, or other software) this is not something we can help 
with. 

This is a Windows course, but we will do our best to 
signpost or handle Mac-related queries within the time we 
have – your slides include extra tips/instructions.

! Mac 
users

https://skills.it.ox.ac.uk/files/itlcpda034slidesnvivowalkingbeforerunningpdf


PRACTICAL WORK

Exercises for you to practise today & materials are all in 

the ITLC Portfolio for downloading

https://skills.it.ox.ac.uk/nvivo-walking-before-running-

code-and-retrieve-course-pack

• There's two of us 

to help you

• You can ask 

questions by 

raising your hand 

in Teams, or use 

the chat

https://skills.it.ox.ac.uk/nvivo-walking-before-running-code-and-retrieve-course-pack


WHAT IS NVIVO?

NVivo is a Computer Assisted Qualitative Data Analysis 
(CAQDAS) software package.

Closeness to data – at least as much as can be had using 
manual methods – is assisted by enlarged and improved 
screen display, improved management of and access to 
multiple sources and types of data, rapid retrieval of coded 
text and easy ability to view retrieved segments of text in their 
original context. (Bazeley and Jackson, 2013).

Helps people manage, shape and make sense of 
unstructured information. It doesn't do the thinking for you; it 
provides a workspace and tools to enable you to easily work 
through your information.’ (QSRinternational.com)
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WHAT IS NVIVO NOT?

 Your data analysis

 An approach to data analysis

 A method of data analysis

 Something that tells you how to do your analysis

 Something that tells you when you’ve come across   

interesting findings

11
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WHAT VERSION, WHAT COMPUTER, 

WHAT’S HAPPENING?

▪ Different versions of NVivo (11, 12 and ‘release 1’ [not 13!])

▪ We will be demonstrating using NVivo v1 for Windows

▪ If you don’t have NVivo 1 for Windows things may look a little 

different… You can open an older version file in newer 

version software but NOT the other way round… [NVivo will 

prompt you]

▪ NVivo for Mac and Windows are different – NVivo for Mac 

generally has less functionality than Windows.

▪ On the Mac, you can do most of what we are showing you today, 

but may have to press slightly different buttons

▪ There is a Windows-Mac Project Converter, but beware of 

converting too many times…

! Mac 
users
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Write down in the Chat some 

different ways or reasons why 

you might need to be 

cautious when using software 

to analyse qualitative data in 

your field.

USING 
SOFTWARE: 
CAUTION…



WORKING WITH QUALITATIVE DATA

Import

Explore

Code

QueryReflect

Visualise

Memo
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▪ Take some time to step 
away from the data.

▪ Save project files on your 
computer and a flash 
drive/secure hard drive.

▪ Try to work backwards from 
what you plan to achieve 
with your data analysis and 
research



THE NVIVO WORKSPACE

List view: displays content of folders Detail view: shows the sources

Navigation 

view
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RIBBON TABS

Top tip

If in doubt, 

right-click 

wherever 

you are, 

see 

available 

options!

Running queries and visualisation functions

Creating documents, memos, codes and classifications

Navigation, coding and classifications

Importing files and project items

16



HELP SYSTEM
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Help from earlier versions like NVivo 11 and 12 = also good



If you’re not sure…
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RIGHT-CLICK in a white space



TIME TO PRACTICE!



Task 1: Create a new Project

i. Open NVivo and click on the ‘New Project’ button.

ii. Leave the ‘Keep a log of user actions’ box unchecked.

iii. Fill in a Project title, eg. Volunteering. Set the Text content 

language.

iv. Review the options Step 2 and click on ‘Create Project’.

Task 2: Review the NVivo Workspace

i. Locate the Navigation view sidebar section. 

ii. Click on different sections.

iii. Review the changes in the list view of the workspace.

EXERCISE 1: Create an 

NVivo Project

20



KEY ELEMENTS: DATA

‘Data’ is where many of the materials 

connected to your NVivo project will 

be stored. In Data you can store data 

in three types of folders: Files, File 

Classifications, and Externals. 

Folders

Noun project: Carla Dias

1. Files: data you import or create in 

NVivo (eg. PDFs, transcripts, audio).

2. File Classifications: ‘labels’ with 

descriptive information assigned to 

Files (e.g. bibliographic information)

3. Externals: links to data you can’t 

import in NVivo (eg. Websites, 

books).

C
re

a
ti
ve
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ta

ll

Dominic White

C
hr

is
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ry

Files

Wilson Joseph

Externals

Author:

Title:

Year:

Publisher:

…

File classifications

TODAY
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Task 1: Import Interviews

i. Create a new folder in Files, name it Interviews.

ii. Click on the Import tab > click Files > Locate the 9 files 

(in ‘Interviews’ > ‘Participant files’).

iii. Leave the box that says ‘Create a case for each 

imported file’ unchecked for now. We will create the 

Cases later.

iv. Click ‘Import’.

EXERCISE 2: Import Files -

Word Documents

22

Check out your Workbook for instructions on importing other types of files ☺



KEY ELEMENTS: NOTES
‘Notes’ is where you can store ideas you 
might have about your project, or things 
you might normally scribble in your 
fieldnotes. In Notes you can store data in 
four types of folders: Memos, Framework 
Matrices, Annotations and See Also Links.

1. Memos: notes and reflections about 

your project.

2. Annotations: notes about a specific 

section of a project item, phrase or 

marking content for follow-up.

3. Framework Matrices: tables for 

summarizing data about  cases and 

 themes. Beware the word limit…

4. See Also Links: marking if a project 

item or section of text might be 

related to another

Memos

Framework 

matrices

TODAY
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EXERCISE 3: Create a Record 

of  Work (a Memo)

▪ Memos can be created for any purpose: what you observe 

during fieldwork, impressions you are left with after an 

interview, content of your coding protocol, strategies for 

analysis, etc.

Create Memos

i. In Notes, highlight the Memos folder > right click in list view > 

select New Memo > name new memo: NVivo course

ii. Create a memo listing the things you have learned thus far.

iii. Create another memo listing your remaining questions.

24



EXERCISE 4:

Creating an Annotation

25

▪ Annotations are useful for sections of text that you are not sure 

what to do with yet, but you want to make a note or comment 

about. Be aware that annotations are not ‘searchable’, 

whereas memos are.

Highlight some text that you’re not sure how to code yet, 

right-click, and select New Annotation. Write some text to 

reflect ideas you might have for a future code you might 

create later. (Annotations are equivalent to Comments in 

Word or PDF documents)

! Mac users: In Detail View, select the content you want to annotate. In the 
context menu, select New Annotation (or keyboard shortcut Shift+⌘+A).



WHAT DATA DO YOU THINK 

YOU CAN PUT INTO 

NVIVO?

26



DATA SOURCES



Interviews/

focus groups

Video files

References

Online data 

(e.g. Twitter, 

Facebook, 

webs, etc.)

Audio files

Memos 

(i.e. your own 

thoughts) DATA SOURCES

Pictures

Check out your Workbook for more details on NVivo’s functionality ☺



Break time…



KEY ELEMENTS: CODES

Codes: ‘containers’ in which wholes or 
parts of sources are kept for analysis.

1. Codes: identified patterns & 
themes (according to data, lit. 
review)

2. Relationships: a type of code that 
defines the connection between 
two project items

3. Relationship types: Different kinds 
of connection available between 
project items

Noun Project | Jars Alex Auda Samora; Person – Stefan Parnarov; Institution – Phil Buchanan

Time

LifeWork

Codes

Sunil is 

‘associated 

with’ Code 

‘Life’

FredricAnna

Anna 

‘employs’ 

Fredric

Relationships

TODAY
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TYPES OF CODING
Coding: the analytical process through which data is fractured, 
conceptualized, and integrated to form theory. (Strauss & 
Corbin)

▪ Deductive Coding

o Codes used by other researches

o Codes developed from literature review/extant theories

▪ Inductive Coding

o Codes developed from raw data

▪ Hybrid Approach

o Deductive & inductive coding

Characteristics of a good code: label; definition; descriptive 
(how/when occurs & any qualifications/exclusions)

*

31



CODES & CODING IN NVIVO

▪ Codes are used to identify a theme, a person, a place, a 
case, etc.

▪ Codes can be organized into hierarchies from a general topic 
(parent code) to specific topics (child codes).

▪ Approaches:

1. Manual coding: codes are created based on selected 
content in the data.

2. Auto-Coding questions: a code is created for each 
question and contains all the answers. (Ideal when working 
with structured data.)

3. Running text queries: a code is created based on the 
results of text searches that retrieve the occurrences of a 
word in the data. (Ideal when the literature review is used 
to generate codes.)

*
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CODING TEXT

▪ Coding at new codes

Select the text > Home or Document tabs > code 

selection at new code

▪ Coding “in vivo”

Select the text  > Home or Document tabs > Code 

In Vivo

▪ Uncoding

Select the text > Home or Document tabs > 

Uncode selection

*
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EXERCISE 5a:

Manual coding: basic, ‘in vivo’ & recent

Exploring what you’ve imported

i. Go into one of your Interview Files – e.g. Anna. Have a look at the 

interview. What structural features do you notice about that File – how are 

the questions and responses arranged and formatted?

ii. What kinds of Codes can you create by inductively coding your Interview 

File? Highlight the text you want to code, right-click and select Code 

Selection. Under Create New, select Top-level Code. Type a name for that 

code that reflects what you have highlighted. Click on OK. Open the Code 

you’ve just created and explore its content.

iii. Using the right-click method, code something ‘In Vivo’ or using ‘Code to 

recent codes’.

34

! Mac users: Select your text in Detail view, go to the Home tab, in the Code menu, 
in Code Selection, click ‘To New Code’, or right-click [Ctrl+click] to see your options. 



EXERCISE 5b:

Manual Coding – dragging & dropping

Create Thematic Codes

i. Create a folder in the Codes area called Theme.

ii. Go to your ‘Interviews’ folder and open the Interview with Grace.

iii. Read the first passage of Grace. She’s talking about ‘doing family 

activities’. Create a code about the notion of Family activities.

iv. Select, drag & drop Grace’s answer to the code Family activities.

v. Review Mary’s answers and code at the same code. (highlight, 

drag & drop).

vi. Create another code called, ‘Elderly home’ and code some text.

35



EXERCISE 6: Visual Markers 

of  Coding

Task 1: Visualize Codes Using Coding Stripes

i. Open any Interview file > go to the ribbon > in the 

Document tab > click on the icon Coding Stripes > 

select Recently Coded.

ii. Coloured stripes appear on the right side of the Detail 

View.

Task 2: Visualize Codes Using Highlight

i. Document tab > Highlight > Select the Codes you 

would like to visualize.
36

! Mac users: Open a file in Detail View. In the View menu, select ‘Coding Stripes’.



Demo: Auto-Coding –

Question codes

i. Create a folder called Questions in the Codes section.

ii. Go to Files > click on the Interviews folder > select the 9 

interviews > right click > click on Auto Code.

iii. In the Auto Code Wizard – Select ‘Code by paragraph styles’.

Step 1: Select Heading 1 and Heading 2, then  the ‘>>’ button 

> Next > Step 2: at the option Under, change to Existing folder

> at the option Name, select Questions folder > OK > Finish.

iv. Review codes in the Questions folder.

37

! Mac users: Auto-coding of Word files is not available on NVivo for 
Mac, but you can auto-code Excel files. Search ‘Autocode datasets’ in 
the Help menu.

https://help-nv.qsrinternational.com/20/mac/Content/coding/automatic-coding-datasets.htm?Highlight=autocoding
https://help-nv.qsrinternational.com/20/mac/Content/welcome.htm


KEY ELEMENTS: CASES
‘Cases’ is where the units of analysis 

and their ‘labels’ connected to your 

NVivo project will be stored. In Cases 

you can store data in two types of 

folders: Cases, and Case 

Classifications.

1. Cases: units of analysis from the data 

(respondent, institution, country) that 

can be ‘coded’ to project items.

2. Case Classifications: ‘labels’ with 

descriptive information assigned to 

demographic, institutional, or 

geographical data about cases. 

Noun Project | Jars Alex Auda Samora; Person – Stefan Parnarov; Institution – Phil Buchanan; 

Demographics Nithinan Tatah

Cases

Anna Phoebe

World Bank

TODAY

Case 

classifications

Age:

Job:

Gender:

…

38



Demo: Auto-Coding - Cases

i. We are now going to create a case for each interview participant.

Return to Files > click on the Interviews folder > select the 9 interviews 

> right click > click on Auto Code again.

ii. In the Auto Code Wizard – Select ‘Code by speaker name’.

iii. Enter all the speaker names – use the ‘Preview’ menu to help you –

make sure the spellings are correct. [The names you will input are: 

Anna, Ben, Bernadette, Fredric, Grace, Ken, Mary, Nick, Phoebe, Sunil]

iv.Click Next when you’re done.

v. Next to ‘Create new classification’, type ‘Respondents’. Click Finish.

vi.You’ll see that a Case has been created for each interview respondent.
39

! Mac users: Create cases from interviews by going to List View, select all your 
interview files > on the Home tab, click ‘Organise’ > ‘Create as Cases’. Then in 
the ‘Classification’ menu, in List view, select your cases and choose a 
Classification. Search ‘Set up cases from interviews’ in the Help menu.

https://help-nv.qsrinternational.com/20/mac/Content/cases/create-cases-automatically.htm#Setupcasesfrominterviews
https://help-nv.qsrinternational.com/20/mac/Content/welcome.htm


CLASSIFICATIONS
▪ Classifications are descriptive information you assign to 

sources or codes.

▪ This information can be used to classify your sources or 

codes by groups which are called Sets.

▪ File classifications are used to store bibliographic 

information about your data.

▪ Case classifications are used to store demographic, 

institutional, or geographical data about case codes.

▪ Your Classification data can be imported from Excel or txt.

▪ If you work with a small number of cases and with few 

attributes, you may want to create a case classification 

directly in NVivo.

*
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Demo: Case Classifications

Task 1: Import Case Classification from Excel

i. Go to the Case Classifications folder > right click in List View > 

click Import Case Classification Sheet. 

ii. In the Wizard step 1 > locate the Case Classification Sheet file 

in the Volunteering Data on your computer 

iii. In Step 3, click the option As names. In the Select location 

window > highlight the folder Cases > OK > Next > Finish.

Task 2: Check that your Cases are classified as ‘Respondents’

i. Go to Cases > select all cases > right click > go down to 

Classification, is ‘Respondents’ selected?

41

! Mac users: Use the ‘.csv’ file to Import your Case Classification sheet, not
the ‘.xlsx’ file.



An example scenario to recap 

everything you’ve just done…



Anna

NVivo: What can I learn about Anna?

43Noun Project | Book - Alice Cerconi; Paper - Creative Stall

WorkTime

Field notes about 

whole research 

project

Video of 

interview with 

Anna Interview 

transcription with 

Anna

Text coded to ‘Work’

Text coded to ‘Time’

Memo about Anna

Text coded to Work

Interview 

transcribed

Typed up 

field notes 

• All data 

referenced to 

Case = Anna

• All data coded 

at Codes 

‘Work’ and 

‘Time’

• Connection 

between 

Codes ‘Work’ 

and ‘Time’ via 

Anna

Code Case = ‘Anna’ to 

(section of) field notes



HOW CAN YOU EXPLORE 

YOUR DATA AFTER CODING 

AT CODES?

You may retrieve all the data relating to a specific person or a 
certain topic in your study.

Use of  timeAnna 



HOW CAN YOU EXPLORE 

YOUR DATA AFTER CODING 

AT CODES?
Using more advanced functionality You may search for content by 
one informant on a particular issue.

Use of  

timeAnna

This is called a ‘coding query’ and there's a step-by-step video here:

https://www.youtube.com/watch?v=Gh2orDf1O9A



RUNNING QUERIES
▪ Word frequency queries identify the most frequently 

occurring words (or sets of similar words around a 
concept).

▪ Text search queries identify all references to a word or 
phrase, also looking for similar words (useful for quick 
coding).

▪ Coding queries look for content coded at selected 
codes, a combination of codes, or a combination of 
codes and attributes.

▪ Compound queries combine text search and coding 
queries, text searches where one term precedes the 
other or two coding queries when content coded at 
one code is near content coded at another.

*

46



EXERCISE 7: Word 

Frequency Searches

i. In the Explore tab > Word Frequency > Set 

parameters > Run Query.

ii. Examine the Word Cloud, Tree Map, and 

Cluster Analysis on the right-hand side of your 

screen.

iii. Re-try your search but eliminate shorter words 

or move the Finding Matches bar from Exact to 

Similar.

47

Check out your Workbook for more details on NVivo’s functionality ☺



EXERCISE 8:

Text Searches
i. In the Explore tab > Text search > Insert: volunteer > Run Query.

ii. Review results in Detail View; Word Tree Tab

iii. Try the same word with an asterisk at the end: volunteer* and see 

the difference in results

iv. Try using the Special instructions button on the right to narrow your 

search:

o Asterisk (*) as a substitute for zero or more characters.

o Question mark (?) as a substitute for a single character.

o Use “” marks for phrases

o You can use Boolean operators AND, OR, NOT or + (required)

o Fuzz search: ‘color~’ will find ‘colors’ or ‘colour’

o Specify proximity: “happy busy” ~102

48
Check out your Workbook for more details on NVivo’s functionality ☺



EXERCISE 9: Creating a 

Codebook
i. Under the Share tab > New Formatted Report (via the Wizard).

ii. Select the option From a view: Code.

iii. Expand the submenu under Code.

iv. Choose Name and Description fields and move to right column.

v. Continue clicking Next. 

vi. Name your report Volunteering Codebook.

vii. Finish.

49

! Mac users: On the Share tab, in the Export menu, select ‘Export 
Codebook’. (Optional: Select which code folders you want to see.) Click 
‘Select’, make any necessary changes (e.g. the format of the codebook), 
then click ‘OK’.



Demo: Matrix Query

The Matrix Query looks for content coded a pair of items and displays 

the results in a table.

Run a Matrix Query

i. Go to Explore > Matrix Coding Query.

ii. In the Matrix Criteria section > in Rows > click on the        > click 

Select Items. 

iii. In the Select Project Items window > highlight the folder Case 

Classification > click on +sign of Age group > tick all values from 

20-29 to 60+. (Do not tick Unassigned & Not Applicable.) > OK.
50

! All users: Don’t worry if your query doesn’t show any results – it could be 
that your case classification import hasn’t worked. You can practise more 
in NVivo sample projects provided by QSR International: search for 

‘sample projects’ in NVivo Help online (or click here for Windows and Mac)

https://help-nv.qsrinternational.com/20/win/Content/about-nvivo/explore-sample-project.htm
https://help-nv.qsrinternational.com/20/mac/Content/about-nvivo/explore-sample-project.htm


Demo: Matrix Query 

(cont’d)

Run a Matrix Query (cont’d)

i. In Columns > click on the        > click Select Items. 

ii. In the Select Project Items window > click on Codes on the left.

iii. On the right, tick all codes > OK.

iv. Click Run. 

By default, the matrix displays the number of coded references for 

each pair of items. 

51

Check out your Workbook for more details on NVivo’s functionality ☺

! All users: Don’t worry if your query doesn’t show any results – it could be that your 
case classification import hasn’t worked. You can practise more in NVivo sample 
projects provided by QSR International: search for ‘sample projects’ in NVivo Help 

online (or click here for Windows and Mac)

https://help-nv.qsrinternational.com/20/win/Content/about-nvivo/explore-sample-project.htm
https://help-nv.qsrinternational.com/20/mac/Content/about-nvivo/explore-sample-project.htm


THINKING AHEAD

NVivo can help you to:

 Manage your data & literature (to keep 
track of and store)

 Manage your ideas and keep a journal 
of the research process

 Ask interesting questions of your data

 Visualise your data, concepts, 
relationships

 Report from the data

Adapted from Bazeley and Jackson 
(2013: 3)
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• Navigate your way round NVivo

• Import text data into NVivo

• Code text data

• Make notes about your data

• Retrieve coded data using ‘queries’

• Float or stay above water…

Learning objectives -

Today you found out how to:



WHAT NEXT?
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Here are some other places on YouTube where you can 

go to find out more about NVivo, and the different 

functionalities. [The videos feature NVivo v12 but the 

principles are the same.] There are many introductory 

mini-lectures on key features of NVivo (qualitative data 

management software) – QSR International:

Please note: these URLs are case-sensitive

• Analysis with NVivo 12 for Windows: 

https://bit.ly/3fBnWq7

• Coding with NVivo 12 for Windows: 

https://bit.ly/3tZN5jC

• Importing data with NVivo 12 for Windows: 

https://bit.ly/3u6rUfC

• Tutorials for NVivo 12 for Mac:

• https://bit.ly/33Z6oPl

Click here to check 

out extra resources in 

the Workbook ☺

https://bit.ly/3fBnWq7
https://bit.ly/3tZN5jC
https://bit.ly/3u6rUfC
https://bit.ly/33Z6oPl
https://skills.it.ox.ac.uk/nvivo-walking-before-running-code-and-retrieve-course-pack


Please note: these URLs are case-sensitive

▪ QSR international have regular webinars and 
tutorials online: https://bit.ly/3fy7JCi

▪ University of Hull have developed online 
tutorials: https://bit.ly/3f4ZzCj

▪ QSR international have step-by-step 
instructions for  NVivo’s full functionality here 
(NVivo 1 for Windows Help System): 
https://bit.ly/3nxBnMU

▪ Download NVivo sample projects provided 
by QSR – search for ‘sample projects’ in 
NVivo Help online (or click here for Windows
and Mac)

If you know of any other helpful resources, 
please let us know 
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Click here to check 

out extra resources in 

the Workbook ☺

https://bit.ly/3fy7JCi
https://bit.ly/3f4ZzCj
https://bit.ly/3nxBnMU
https://help-nv.qsrinternational.com/20/win/Content/about-nvivo/explore-sample-project.htm
https://help-nv.qsrinternational.com/20/mac/Content/about-nvivo/explore-sample-project.htm
https://skills.it.ox.ac.uk/nvivo-walking-before-running-code-and-retrieve-course-pack


Thank you!

All the best with your research and 
adventures with NVivo ☺



This presentation is made available by Susila Davis, Charlotte Albury, Zainab 
Kabba and Marie-Hélène Paré under a Creative Commons licence:

Attribution-NonCommercial-ShareAlike
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