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Effective Workflows



The small print

Prerequisites
Time in the workshop is precious – it is an opportunity for you to interact with the 
workshop leader and other participants through questions and discussions and to 
share your experiences and concerns. To make the most of this time we sometimes 
ask you to carry out learning activities ahead of the workshop so that everyone 
comes into the class with the same basic knowledge. We keep this prior learning to 
a minimum and often make use of online videos. Online videos provided through 
LinkedIn Learning can be accessed free of charge by University members anytime, 
anywhere, through a browser or app.

Your course booking will tell you if any prior learning activity is required. If you don’t 
have an environment where you can do this learning, you can come along to one of 
our LinkedIn Learning sessions. These are a quiet space where you can work through 
videos or other workshop resources.

If you arrive for a workshop without having done the prior learning, the workshop 
leader may suggest that you come back on another session.

Copyright
Carl Wenczek makes this booklet and the accompanying slides available under a 
Creative Commons licence (BY-NC-SA: Attribution-NonCommercial-ShareAlike).

The Oxford University crest and logo and IT Services logo are copyright of the 
University of Oxford and may only be used by members of the University in 
accordance with the University’s branding guidelines.

About the workshop designer
Carl Wenczek is a very experienced architectural illustrator and an expert in 3d 
modelling and 2d imaging.  He is a Director of his own small company and over the 
last 18 years has built long lasting relationships with his clients, creating 100’s of 
illustrations and helping them convey their ideas and designs.

Running parallel to his commercial work, Carl is also a part-time lecturer in 
multimedia and has been teaching at Oxford University’s IT Services for the last 17 
years, delivering courses in Photoshop, Illustrator, InDesign, After Effects, Blender, 
GIMP, Inkscape and digital photography.

Carl also coaches Paddlesport (kayaking, canoeing and stand up paddling) and 
Indoor Climbing.  These sports are often coached in demanding and dynamic 
environments and require a calm persona! 

Revision history
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2.2	 September 2022		  Carl Wenczek		  Text changes to clarify the instructions for 		
								        Photoshop and GIMP, checked links



About this workshop

Does your research paper or departmental web site need eye-catching images?  The 
aim of this workshop is to introduce you to the general principles and techniques for 
working with digital images.

What you will learn
We will be using Adobe Photoshop or GIMP.  You will be introduced to a model 
workflow for image manipulation and correction, preparing images for documents 
and presentations and for optimising images for the web.

What you need to know
You do not need any prior knowledge of Adobe Photoshop or GIMP.

This workshop will cover:

•	Correcting and improving images
•	Using a model workflow
•	Preparing images for documents, presentations and the web
•	Output
•	Good working practices

If you need to review these activities, LinkedIn Learning is a great place to get 
guidance. There is an activity with relevant videos in the IT Learning Portfolio: visit 
skills.it.ox.ac.uk/it-learning-portfolio and search for “Photoshop”, “GIMP” or “Images 
activity”.

The resources you need
Sample documents that you can use to experiment with will be made available, but 
you may like to bring along your own.

The resources for most workshops, including any pre-course activity, are in the 
IT Learning Portfolio: visit skills.it.ox.ac.uk/it-learning-portfolio and search for 
“Photoshop”, “GIMP” or “Images”.

Unless you have been told otherwise, in classroom workshops there will be a 
computer available for you to use with Adobe Photoshop or GIMP installed.

You can use your own computer with your preferred app installed if you want to 
– just bear in mind that I am not an expert in every app (although I am sure that 
between us we will be able to sort out most problems!)
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Learning Objective 01 - Work with a RAW image

A RAW file is an uncompressed version of an image file.  The camera takes 
the image data from the sensor and saves it in an unedited (unprocessed) and 
uncompressed format on the memory card.

RAW files contain many more shades of colours compared to JPEG files - RAW 
files have 12 or 14 bits of intensity information per channel (4096-16384 shades), 
compared to JPEG’s 8 bits (256 shades).

For more information see the handout and the link below:

https://en.wikipedia.org/wiki/Raw_image_format

For Photoshop use:
• Adobe Camera RAW.  Camera Raw gives you everything you need for 
processing raw images.

For GIMP use:
• A third party plugin such as UFRaw.



Learning Objective 02 - Rotate, Crop and apply Lens Corrections

Cropping is one of the most fundamental photo manipulation processes.  It is 
usually carried out to remove an unwanted object or to tidy up the edges of a 
photograph, to change its aspect ratio or to improve the overall composition.

As a compositional tool, cropping can be used for dramatic effect or to help create a 
focal point.

For Photoshop:
• Use the Lens Correction Filter and the Crop Tool.

• To make the cropping process non-destructive, deselect Delete Cropped 
Pixels.

For GIMP:
• Use Filters>Distorts>Lens Distortion, the Rotate Tool, the 
Perspective Tool and the Crop Tool.



Learning Objective 03 - Repair an image

Photoshop or Photoshopping
2. (transitive verb)
to alter (a digital image) using Photoshop or other image editing software

It’s always good to try and get your photographs right in-camera but there are 
times when this isn’t possible.  Perhaps you had your thumb over the lens or you 
have a distracting object in the background that you didn’t notice when you took 
the photograph.  Old, scanned images may be damaged and need repairing.  New 
photographs may include specks caused by dust on the digital sensor.

It is possible to remove unwanted parts of your photographs by covering them up 
with details from other parts of the photograph.  You can “clone” from one part of 
an image to another.

For Photoshop use:
• The Clone Stamp Tool or the Healing Brush Tool.

• ALT + Click to set the clone source and then click-and-drag to paint over the 
area you want to repair/remove.

For GIMP use:
• The Clone Tool or the Healing Tool.

• CTRL + Click to set the clone source and then click-and-drag to paint over the 
area you want to repair/remove.



Learning Objective 04 - Apply Tonal range and colour 
adjustments

Tonal range is the measure of image brightness from the darkest pixels (black) to 
the lightest pixels (white).  The range between the different brightness levels within 
your images determines it’s degree of contrast:

Tonal range and colour can be adjusted using a variety of tools and techniques.

For Photoshop use:
• Levels for tonal range adjustment and either Hue/Saturation or Colour 
Balance for colour adjustments.

For GIMP use:
• Levels for tonal range adjustment and either Hue-Saturation or Colour 
Balance for colour adjustments.

High Medium Low



Learning Objective 05 - Apply Selective corrections

Until now we have worked on global corrections, but images my require different 
adjustments and corrections in different areas.

In our workflow, we always start with global corrections and then select the areas 
that remain and apply local adjustments.  To do this we can select specific parts of 
the image using a wide variety of selection tools and then edit those regions without 
affecting the rest of the image.

Selection tools fall into the following categories:

Type Photoshop GIMP
Manual Rectangular 

Marquee, Elliptical 
Marquee, Lasso, 
Polygonal Lasso

Rectangular Select, 
Ellipse Select, Free 
Select

Assisted Magnetic Lasso, 
Quick Selection

Scissors Select

Colour based Magic Wand, 
Eyedropper

Select by Color, 
Color Picker

For GIMP:
• Make selections and then apply adjustments in the usual way.

For Photoshop:

• Make selections and then apply adjustments in the usual way.

For Photoshop only:
• In order to make the process non-destructive use Adjustment Layers.

• First make your selection

• Then choose Layer>New Adjustment Layer.



Learning Objective 06 - Adjust Image Size for screen and print

For Screen

• Pixel dimensions only.

When it comes to displaying images on a screen you need to be aware of the size of 
the screen or monitor you will be using to display your images.  For example, to fill 
a monitor that is 1920 by 1080 pixels in size so, you will need an image that is 1920 
by 1080 pixels in size.

Date Other High 1920x1080 1366x768 1280x1024 1280x800 1024x768 Lower

January 
2021

41.5% 19.2% 24.8% 1.2% 1.5% 1.1% 10.7%

https://www.w3schools.com/browsers/browsers_display.asp

For Print

• Print size/document size.

• Resolution.

When preparing images for print you need to decide on the size you want to print 
the image (it’s print or document size), and the pixel density or resolution (pixels 
per inch (ppi)).  You might also need to decide if your image is big enough, see 
examples below:

Print size (mm) Resolution (ppi) Pixel dimensions
A4 300 2840 x 3508

150 1240 x 1754
A3 300 3508 x 4961
A2 300 4961 x 7016

Nikon D750, 25 megapixels = 6016 x 4016

• For Photoshop choose Image>Image Size.

• For GIMP choose Image>Scale Image (for screen) or Print Size (for print).



Learning Objective 07 - Sharpen an image

Sharpening is a technique for increasing the apparent sharpness of an image.  It 
can be used to emphasize texture and draw viewer focus.  Sharpening needs to be 
carried out carefully because if it is applied too aggressively artifacts may appear or 
an image can appear too sharp when printed.  For more information see
https://www.cambridgeincolour.com/tutorials/image-sharpening.htm

Capture 
Sharpening

Creative 
Sharpening

Output 
Sharpening

Reduce blurring 
caused by the 
source of your 
image e.g. camera 
sensor, camera 
lens

Applied selectively 
and for artistic 
purposes

Appropriate to 
final media and to 
offset any softening 
caused by resizing 
an image

Common settings

Radius:  Controls the size of the edges you wish to enhance, where a smaller 
radius enhances smaller-scale detail.  Choose a radius setting that is comparable to 
the size of the smallest detail within your image.  Try starting at a value of 1.

Amount:  Controls the overall strength of the sharpening effect, and is usually 
listed as a percentage.  Try starting at a value of 100%.

Threshold (Masking):  Controls the minimum brightness change that will be 
sharpened.  This can be used to sharpen more pronounced edges, while leaving 
more subtle edges untouched.  It is especially useful to avoid sharpening noise.

• For Photoshop use Smart Sharpen and Unsharp Mask filters.

• For GIMP use the Sharpen and Unsharp Mask filters.



Learning Objective 08 - Save your images

Save your images as you are working on them in a native file format such as .psd 
(Photoshop) or .xcf (GIMP).

Master
.psd, .xcf

These native file formats retain information such as layers, adjustments and 
masks.

Once you have finished working on your images the file format you choose will 
depend on your intent.

Web
.jpeg, .gif, .png

Used for websites.  GIF is more suitable for text and graphics and supports 
transparency.  JPEG for photographs and realistic images.  PNG for line 
art, text-heavy images, and images with few or solid colours, uses lossless 
compression and supports transparency.

Print
.jpeg (maximum quality), .tiff

TIFF is a lossless file format meaning it does not lose any image quality making 
it suitable for high quality prints and archival copies.

• For Photoshop use the Save As and Save for Web commands.

• For GIMP use the Save As and Export As commands.



Learning Objective 09 - Create Batch processes

Sometimes you might have a lot of images you need to edit. You may need them all 
at a specific size or want them all to follow a specific naming convention.  Rather 
than editing them one by one you might want to consider setting up a batch process 
to do the work for you.

There are many standalone Batch Image Processors available.  However, 
Photoshop comes with this feature included in the form of Actions and the Batch 
command.

For Photoshop:
• Use the Actions panel.

A Photoshop Action allows you to record a series of steps and then play the 
sequence back to apply those effects on a single image or a batch of files.

• To run an Action on a series of images choose File>Automate>Batch.

For GIMP:
• Use the Batch Mode, see https://www.gimp.org/tutorials/Basic_Batch/.



Learning Objective 10 (Optional) - Use Masks to blend images

Layer masks are a fundamental tool in image manipulations.  They allow you 
to selectively modify the opacity (transparency) of the layer they belong to.  
This differs from the use of the layer Opacity slider as a mask has the ability to 
selectively modify the opacity of different areas across a single layer.

This modification of a layer’s transparency through a mask is non-destructive to the 
layer itself.

For Photoshop:
• Use Layer Masks.  Choose Layer>Layer Mask.

For GIMP:
• Use Layer Masks.  Choose Layer>Mask>Add Layer Mask.



For the “correcting and improving courses” - TIMN, TIMNM, TIMNG - print at A5

Correcting and Improving 
your images
a digital workflow

Evaluate image
Rotate, crop and correct perspective
Reduce noise and repair blemishes
Capture Sharpening
Tonal range adjustment
Colour balance
Saturation
Selective correction
Fine tuning of colours
Adjust mid-tone contrast
Resize image for final media
Sharpen for final media





















Further information

Getting extra help

Course Clinics
The IT Learning Centre offers bookable clinics where you can get pre- or post-course 
advice. Contact us using courses@it.ox.ac.uk.

Study Videos from LinkedIn Learning
On our website, you will find our collection of self-service courses and resources. This 
includes providing LinkedIn Learning video-based courses free to all members of the 
University. Visit skills.it.ox.ac.uk/linkedin-learning and sign in with your Single Sign-
On (SSO) credentials.

Some courses recommend pre- and/or post-course activities to support your learning. 
You can watch the online videos anywhere, anytime, and even download them onto a 
tablet or smartphone for off line viewing. 

About the IT Learning Portfolio online
Many of the resources used in the IT Learning Centre courses and workshops are 
made available as Open Educational Resources (OER) via our Portfolio website at 
skills.it.ox.ac.uk/it-learning-portfolio.

Find the pre-course activity for this course in the IT Learning Portfolio: visit 
skills.it.ox.ac.uk/it-learning-portfolio and search for “Photoshop”, “GIMP” or “Images 
activity”.

About the IT Learning Centre
The IT Learning Centre delivers over 100 IT-related teacher-led courses, which are 
provided in our teaching rooms and online, and we give you access to thousands of 
on-line self-service courses through LinkedIn Learning.

Our team of teachers have backgrounds in academia, research, business and 
education and are supported by other experts from around the University and 
beyond.

Our courses are open to all members of the University at a small charge. Where 
resources allow, we can deliver private courses to departments and colleges, which 
can be more cost-effective than signing up individually. We can also customize 
courses to suit your needs.

Our fully equipped suite of seven teaching and training rooms are usually available 
for hire for your own events and courses.

For more information, contact us at courses@it.ox.ac.uk.



About IT Customer Services
The IT Learning Centre is part of the Customer Services Group. The group provides 
the main user support services for the department, assisting all staff and students 
within the University as well as retired staff and other users of University IT services. 
It supports all the services offered by IT Services plus general IT support queries from 
any user, working in collaboration with local IT support units.

The Customer Services Group also offers a data back-up service; an online shop; 
and a computer maintenance scheme. Customer Services is further responsible for 
desktop computing services – for staff and in public/shared areas – throughout UAS 
and the Bodleian Libraries.

For information about future GIMP updates
Visit https://developer.gimp.org/core/roadmap/


